您的位置:首页 > 其它

hdu 1024 最大M子段和

2016-03-28 10:06 363 查看

Max Sum Plus Plus

[b]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 23234    Accepted Submission(s): 7922
[/b]

[align=left]Problem Description[/align]
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define
a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im,
jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^

 
[align=left]Input[/align]
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.

Process to the end of file.

 
[align=left]Output[/align]
Output the maximal summation described above in one line.

 
[align=left]Sample Input[/align]

1 3 1 2 3
2 6 -1 4 -2 3 -2 3

 
[align=left]Sample Output[/align]

6
8

Hint
Huge input, scanf and dynamic programming is recommended.

 
[align=left]Author[/align]
JGShining(极光炫影)

推荐两篇blog:http://blog.sina.com.cn/s/blog_677a3eb30100jxqa.html

                            http://www.cnblogs.com/kuangbin/archive/2011/08/04/2127085.html
#include <iostream>
#include<cstring>
#include<algorithm>
using namespace std;

int main()
{
int m,n;
int i,j;
int max_dp;
while(cin>>m>>n)//求n个数的数列的最大m子段和
{
int *a=new int[n+1];
int *dp=new int[n+1];//dp[j]表示包括a[j]在内的最大i子段和
int *pre_max_dp=new int[n+1];//pre_max_dp[j]表示a[1]~a[j]的最大i-1子段和

//初始化
for(int count=1;count<=n;count++)
{
dp[count]=0;
pre_max_dp[count]=0;
cin>>a[count];
}
dp[0]=pre_max_dp[0]=0;

for(i=1;i<=m;i++)
{
max_dp=INT_MIN;//max_dp表示a[1]~a[j]的最大i子段和,初始化为不可能值
for(j=i;j<=n;j++)//j有i个子段,j>=i
{
dp[j]=max(dp[j-1]+a[j],pre_max_dp[j-1]+a[j]);
pre_max_dp[j-1]=max_dp;//更新数据,在i++后使用
max_dp=max(max_dp,dp[j]);
}
}
cout<<max_dp<<endl;//结束后的max_dp即为a[1]~a
的最大m子段和
delete[] a;
delete[] dp;
delete[] pre_max_dp;
}//end of while
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  dp