您的位置:首页 > 其它

hdoj--2407--Knots(规律题)

2016-03-27 19:59 190 查看


Knots

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 249    Accepted Submission(s): 172


Problem Description

An even number N of strands are stuck through a wall. On one side of the wall, a girl ties N/2 knots between disjoint pairs of strands. On the other side of the wall, the girl's groom-to-be also ties N/2 knots between disjoint pairs of strands. You are to find
the probability that the knotted strands form one big loop (in which case the couple will be allowed to marry). 

For example, suppose that N = 4 and you number the strands 1, 2, 3, 4. Also suppose that the girl has created the following pairs of strands by tying knots: {(1, 4), (2,3)}. Then the groom-to-be has two choices for tying the knots on his side: {(1,2), {3,4)}
or {(1,3), (2,4)}.

 

Input

The input file consists of one or more lines. Each line of the input file contains a positive even integer, less than or equal to 100. This integer represents the number of strands in the wall.

 

Output

For each line of input, the program will produce exactly one line of output: the probability that the knotted strands form one big loop, given the number of strands on the corresponding line of input. Print the probability to 5 decimal places.

 

Sample Input

4
20

 

Sample Output

0.66667
0.28377

 

Source

ACM/ICPC
2008 Warmup(2)——测试帐号(杭州)

 

Recommend

额,队友模拟了好多找出来的规律,真是不容易啊

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#define ll long long
#define N 1010
#define M 1000000007
using namespace std;
double s[110];
int main()
{
int t,n,m;
int i,j,k;
s[2]=1;
for(i=4;i<=100;i+=2)
{
double ss=(i-2)*1.0/(i-1);
s[i]=s[i-2]*ss;
}
while(scanf("%d",&n)!=EOF)
{
printf("%.5lf\n",s
);
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: