您的位置:首页 > 其它

HDU 3172 Virtual Friends (并查集)

2016-03-27 19:39 381 查看
Problem Description

These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends' friends, their friends' friends' friends, and so on), has become
an addictive hobby. Just as some people collect stamps, other people collect virtual friends.

Your task is to observe the interactions on such a website and keep track of the size of each person's network.

Assume that every friendship is mutual. If Fred is Barney's friend, then Barney is also Fred's friend.

Input

Input file contains multiple test cases.

The first line of each case indicates the number of test friendship nest.

each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by
a space. A name is a string of 1 to 20 letters (uppercase or lowercase).

Output

Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.

Sample Input

1
3
Fred Barney
Barney Betty
Betty Wilma


Sample Output

2
3
4


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
using namespace std;
const int N = 100000 +10;
int num
,fa
;
map<string,int>pre;
char name1[22],name2[22];

int find(int x)
{
int r=x;
while(fa[r]!=r) r=fa[r];
int i=x,j;
while(i!=r) {
j=fa[i];
fa[i]=r;
i=j;
}
return r;
}

int main()
{
int T,i,j,n,k;
int x,y,fx,fy;
while(scanf("%d",&T)!=EOF) {
while(T--) {
pre.clear();
scanf("%d",&n);
for(i=1;i<N;i++) {
fa[i]=i;
num[i]=1;
}
k=0;
while(n--) {
scanf("%s%s",name1,name2);
if(!pre[name1]) pre[name1]=++k;
if(!pre[name2]) pre[name2]=++k;
fx=find(pre[name1]);
fy=find(pre[name2]);
if(fx!=fy) {
fa[fx]=fy;
num[fy]+=num[fx];
}
printf("%d\n",num[fy]);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: