您的位置:首页 > 其它

hdoj Joseph 1443 (约瑟夫环&打表)

2016-03-27 15:48 302 查看

Joseph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2228    Accepted Submission(s): 1352


[align=left]Problem Description[/align]
The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of
the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order
5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy. 

 

[align=left]Input[/align]
The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14. 

 

[align=left]Output[/align]
The output file will consist of separate lines containing m corresponding to k in the input file. 

 

[align=left]Sample Input[/align]

3
4
0

 

[align=left]Sample Output[/align]

5
30//题意:给你一个n,表示有n个好人,另外有n个坏人,现在好人和坏人站成一个环,好人站在前n个位置,现在进行报数,每次报到m的人将会拉出去枪毙(O_O),现在要求在坏人被枪决完之前不能枪决好人,问这个m最小是多少。
#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
#define INF 0x3f3f3f3f
#define IN __int64
#define ull unsigned long long
#define ll long long
#define N 10010
#define M 1000000007
using namespace std;
int k;
int dp[15];
bool solve(int m)
{
int cur=0;
for(int i=1;i<=k;i++)
{
if((cur+m-1)%(2*k-i+1)<k)
return false;
cur=(cur+m-1)%(2*k-i+1);
}
return true;
}
int main()
{
for(k=1;k<15;k++)
{
int i;
for(i=1;;i++)
{
if(solve(i))
break;
}
dp[k]=i;
}
while(~scanf("%d",&k),k)
{
printf("%d\n",dp[k]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: