您的位置:首页 > 编程语言 > PHP开发

HDU_ACM_A+B for Input-Output Practice (III)

2016-03-26 23:54 597 查看
<span style="font-family: Arial, Helvetica, sans-serif; background-color: rgb(255, 255, 255);">问题描述:</span>

[align=left]Problem Description[/align]
Your task is to Calculate a + b.
问题描述:
你的任务是计算a+b 

[align=left]Input[/align]
Input contains multiple test cases. Each test case contains a pair of integers a and b, one pair of integers per line. A test case containing 0 0 terminates the input and this test case is not to be processed.

 输入:
输入包含多个测试用例。每个测试用例包含一对整数a和b,每行有一对整数。0 0代表结束输入同时也代表测试用例的结束
[align=left]Output[/align]
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

 输出:
每行输入的一对整数a  b应该对应有a+b的和作为输出,每一行的输入对应有一行的输出
[align=left]Sample Input[/align]
[align=left]输入示例:[/align]

1 5
10 20
0 0


 
[align=left]Sample Output[/align]
[align=left]输出示例:[/align]

6
30


#include "stdio.h"
int main()
{
<span style="white-space:pre">	</span>int a,b;
<span style="white-space:pre">	</span>while(scanf("%d%d",&a,&b)!=EOF)
<span style="white-space:pre">	</span>{
<span style="white-space:pre">		</span>if(a==0&&b==0){
<span style="white-space:pre">		</span>return 0;
<span style="white-space:pre">		</span>}
<span style="white-space:pre">		</span>else{
<span style="white-space:pre">		</span>printf("%d\n",a+b);
<span style="white-space:pre">		</span>}
<span style="white-space:pre">	</span>}
<span style="white-space:pre">	</span>return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM HDOJ C语言