您的位置:首页 > 其它

hdoj 1052 Tian Ji -- The Horse Racing

2016-03-26 18:01 381 查看
Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 24831 Accepted Submission(s): 7236

Problem Description

Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from
the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you
think of Tian Ji, the high ranked official in China?"

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's
horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find
the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too
advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.

Input

The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers
on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.

Output

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

Sample Input

3

92 83 71

95 87 74

2

20 20

20 20

2

20 19

22 18

0

Sample Output

200

0

0

田忌赛马真的不容易,,,,佩服他,,,

模拟赛马过程,,马相同时最难了。。。。

更简单代码请点击这里

代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int tian[1050];
int qi[1050];
bool cmp(int xx,int yy)
{
return xx>yy;
}
int main()
{
int n,s;
while (~scanf("%d",&n))
{
memset(tian,0,sizeof(tian));
memset(qi,0,sizeof(qi));
for (int i=0;i<n;i++)
scanf("%d",&tian[i]);
for (int i=0;i<n;i++)
scanf("%d",&qi[i]);
sort(qi,qi+n);
sort(tian,tian+n);
s=0;
for (int i=0;i<n;i++)
{
if (tian[i]>qi[i])//田win
s+=100;
else if (tian[i]<qi[i])//田wrong,,,让它和齐的最快的比
{
s-=100;
for (int j=n-1;j>i;j--)
qi[j]=qi[j-1];
}
else//相等时。。。。这个最难想///
{
if (tian[n-1]>qi[n-1])//田忌最快>齐王最快,先比他们,其他后移。。。
{
s+=100;
for (int j=n-1;j>i;j--)
qi[j]=qi[j-1];
for (int j=n-1;j>i;j--)
tian[j]=tian[j-1];
}//田最快不win齐最快时,,
else if (tian[i]<qi[n-1])//他们剩下的马的速度不全相同时,让田的最慢的与齐的最快的比,,,
//虽然这次输,但下次是田的i+1与齐的i(=田的i)比,,,田的最大的与齐的次大的比。。。

{
s-=100;
for (int j=n-1;j>i;j--)
qi[j]=qi[j-1];
}//剩下的马全一样,,以后一样无作为。。。。
}
}
printf("%d\n",s);
}
return 0;
}


代码2:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,tian[1050],wang[1050];
int main()
{
while (scanf("%d",&n),n)
{
for (int i=1;i<=n;i++)
scanf("%d",&tian[i]);
for (int i=1;i<=n;i++)
scanf("%d",&wang[i]);
sort(wang+1,wang+1+n);
sort(tian+1,tian+1+n);
int tiku=n,waku=n,ti=1,wa=1;
int s=0;
while (n--)
{
if (tian[ti]>wang[wa])
{
s++;ti++;wa++;
}
else if (tian[ti]<wang[wa])
{
s--;ti++;waku--;
}
else
{
if (tian[tiku]>wang[waku])
{
s++;tiku--;waku--;
}
else if (tian[ti]<wang[waku])
{
s--;ti++;waku--;
}
else
{
ti++;waku--;
}
}
//	printf("%d   66\n",s);
}
printf("%d\n",s*200);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: