您的位置:首页 > 其它

poj1731(dfs实现全排列)

2016-03-26 17:05 411 查看
Orders

Time Limit: 1000MS Memory Limit: 10000K

Total Submissions: 10087 Accepted: 6109

Description

The stores manager has sorted all kinds of goods in an alphabetical order of their labels. All the kinds having labels starting with the same letter are stored in the same warehouse (i.e. in the same building) labelled(贴上标签的) with this letter. During the day the stores manager receives and books the orders of goods which are to be delivered from the store. Each order requires only one kind of goods. The stores manager processes the requests in the order of their booking.

You know in advance all the orders which will have to be processed by the stores manager today, but you do not know their booking order. Compute all possible ways of the visits of warehouses for the stores manager to settle all the demands piece after piece during the day.

Input

Input contains a single line with all labels of the requested goods (in random order). Each kind of goods is represented by the starting letter of its label. Only small letters of the English alphabet are used. The number of orders doesn’t exceed 200.

Output

Output will contain all possible orderings in which the stores manager may visit his warehouses. Every warehouse is represented by a single small letter of the English alphabet – the starting letter of the label of the goods. Each ordering of warehouses is written in the output file only once on a separate line and all the lines containing orderings have to be sorted in an alphabetical order (see the example). No output will exceed 2 megabytes(兆字节).

Sample Input

bbjd

Sample Output

bbdj

bbjd

bdbj

bdjb

bjbd

bjdb

dbbj

dbjb

djbb

jbbd

jbdb

jdbb

先升序排序,然后从开始往下找,找之前没有找过的,然后取,取完之后往回退一步,继续往下找,一直遍历所有情况为止。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<stdlib.h>
#include<cstring>
using namespace std;
int vis[202],cnt;
char in[202],out[202];
int cmp(char a,char b){
return a<b;
}
void dfs(int len){
int i;
char c='\0';
if(len==cnt){
out[cnt]='\0';
printf("%s\n",out);
}
for(i=0;i<cnt;i++){
if(!vis[i]&&in[i]!=c){
vis[i]=1;
out[len]=in[i];
c=in[i];
dfs(len+1);
vis[i]=0;
}
}
}
int main(){
while(scanf("%s",in)!=EOF){
sort(in,in+strlen(in),cmp);
memset(vis,0,sizeof(vis));
cnt=strlen(in);
dfs(0);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: