您的位置:首页 > 其它

PAT (Advanced Level) Practise 1105 Spiral Matrix (25)

2016-03-26 15:42 507 查看


1105. Spiral Matrix (25)

时间限制

150 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The
matrix has m rows and ncolumns, where m and n satisfy the following: m*n must be equal to N; m>=n; and m-n is
the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 104. The
numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.
Sample Input:
12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:
98 95 93
42 37 81
53 20 76
58 60 76
简单的排列一下数字。
#include<cstdio>
#include<vector>
#include<queue>
#include<string>
#include<map>
#include<cmath>
#include<iostream>
#include<cstring>
#include<functional>
#include<algorithm>
using namespace std;
typedef long long LL;
const int INF = 0x7FFFFFFF;
const int maxn = 1e4 + 10;
int n, a[maxn], x, y, vis[maxn];
vector<int> c[maxn];
int u[4] = { 0, 1, 0, -1 };
int v[4] = { 1, 0, -1, 0 };

int main()
{
scanf("%d", &n);
for (int i = 0; i < n; i++) scanf("%d", &a[i]);
for (int i = 1; i*i <= n; i++)
{
if (n % i == 0)
{
x = n / i; y = i;
}
}
for (int i = 1; i <= x; i++)
{
for (int j = 0; j <= y; j++) c[i].push_back(0);
}
sort(a, a + n, greater<int>());
int vec = 0, X = 1, Y = 1;
for (int i = 0; i < n; i++)
{
c[X][Y] = a[i]; vis[(X - 1)*y + Y - 1] = 1;
if (X + u[vec]>x || X + u[vec] < 1 || Y + v[vec]< 1 || Y + v[vec]>y) vec = (vec + 1) % 4;
else if (vis[(X + u[vec] - 1) * y + Y + v[vec] - 1]) vec = (vec + 1) % 4;
X += u[vec]; Y += v[vec];
}
for (int i = 1; i <= x; i++)
{
for (int j = 1; j <= y; j++)
{
printf("%d%s", c[i][j], j == y ? "\n" : " ");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT