您的位置:首页 > 其它

题目1001:A+B for Matrices

2016-03-26 13:20 501 查看
题目1001:A+B for Matrices

时间限制:1 秒内存限制:32 兆

题目描述:

This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.

输入:

The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.

The input is terminated by a zero M and that case must NOT be processed.

输出:

For each test case you should output in one line the total number of zero rows and columns of A+B.

样例输入:

2 2

1 1

1 1

-1 -1

10 9

2 3

1 2 3

4 5 6

-1 -2 -3

-4 -5 -6

0

样例输出:

1

5

----------------

代码有bug,测试数据不够严谨. AC了。。。。

----------------------------------------------------

import java.util.Scanner;
public class Main {

public static void main(String[] args) {
// TODO Auto-generated method stub
Scanner sc=new Scanner(System.in);
while(sc.hasNext()){
int m=sc.nextInt();
if(m==0)break;
int n=sc.nextInt();
int a[][]=new int[m]
;
int b[][]=new int[m]
;
int c[][]=new int[m]
;
int zorerow=0;
int zorecol=0;
for(int i=0;i<m;i++)
for(int j=0;j<n;j++)
a[i][j]=sc.nextInt();
for(int i=0;i<m;i++)
for(int j=0;j<n;j++){
b[i][j]=sc.nextInt();
c[i][j]=a[i][j]+b[i][j];
}

int temp=0;
int tmp=0;
for(int i=0;i<m;i++){
for(int j=0;j<n;j++){
temp+=c[i][j];
}
if(temp==0)zorerow++;
temp=0;
}
for(int j=0;j<n;j++){
for(int i=0;i<m;i++){
tmp+=c[i][j];
}
if(tmp==0)zorerow++;
tmp=0;
}

System.out.println(zorerow+zorecol);
}

}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: