您的位置:首页 > 其它

1006 of strategy

2016-03-25 23:23 225 查看
Problem Description

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to
move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

 

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

 

Output

Print the total time on a single line for each test case.

 

Sample Input

1 2
3 2 3 1
0

 

Sample Output

17
41

 题目要求:提供电梯要经过的楼层,算出运行的时间。

 思路:直接进行上6下4停5的过程进行计算。

 细节:没有什么坑,又是一道签到题。

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
int i,j,n,sum=0;
int a[101]={0};
while(scanf("%d",&n))
{
if(n==0)break;
j=n;sum=5*n;
while(n--)
scanf("%d",&a[n+1]);
for(i=j-1;i>0;i--)
if(a[i]>a[i+1])sum+=(a[i]-a[i+1])*6;
else sum+=(a[i+1]-a[i])*4;
sum+=a[j]*6;
printf("%d\n",sum);
}

}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: