您的位置:首页 > 其它

hdu1016(dfs实现环状全排序)

2016-03-25 22:11 519 查看
Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 39348 Accepted Submission(s): 17338

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.



Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely(顺时针方向的) and anticlockwisely(逆时针的). The order of numbers must satisfy the above requirements. Print solutions in lexicographical(辞典编纂的) order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6

8

Sample Output

Case 1:

1 4 3 2 5 6

1 6 5 2 3 4

Case 2:

1 2 3 8 5 6 7 4

1 2 5 8 3 4 7 6

1 4 7 6 5 8 3 2

1 6 7 4 3 8 5 2

题解:第一个数从2到n开始往下找,标记此数,然后继续第二个数从2到n开始往下找,标记此数,找到了第n个数的时候把它打印出来,然后往回退一个,继续往下找,以此类推,直到找完所有的情况为止。

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
//int prime[42]={0,0,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,1,0,1,0,0,0,0,0,1,0,0,0,1};
int vis[21],a[21],n;
bool prime(int n){
int k,i;
if(n<2)return false;
for(i=2;i<=(int)sqrt(n);i++){
if(n%i==0)return false;
}
return true;
}
void dfs(int k){
int i;
if(k==n&&prime(a[0]+a[n-1])){
for(i=0;i<n-1;i++)
printf("%d ",a[i]);
printf("%d\n",a[n-1]);
}
else{
for(i=2;i<=n;i++){
if(!vis[i]){
if(prime(a[k-1]+i)){
vis[i]=1;
a[k++]=i;
dfs(k);
vis[i]=0;
k--;
}
}
}
}

}
int main(){
int i;
i=1;
while(scanf("%d",&n)!=EOF){
printf("Case %d:\n",i);
memset(vis,0,sizeof(vis));
a[0]=1;
dfs(1);
i++;
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: