您的位置:首页 > 其它

PAT (Advanced Level) Practise 1096 Consecutive Factors (20)

2016-03-25 21:10 447 查看


1096. Consecutive Factors (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number
of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<231).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format "factor[1]*factor[2]*...*factor[k]", where the factors are listed in increasing
order, and 1 is NOT included.
Sample Input:
630

Sample Output:
3
5*6*7

找连续的因子,因为范围不超过int,那其实最多能连续的也就12!来着的,所以暴力搞
#include<cstdio>
#include<vector>
#include<map>
#include<queue>
#include<string>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int INF = 0x7FFFFFFF;
const int maxn = 2e3 + 10;
LL n;

int main()
{
scanf("%lld", &n);
for (LL i = 11; i > 1; i--)
{
for (LL j = 2;; j++)
{
LL cnt = 1;
for (LL k = j; k < j + i; k++) cnt *= k;
if (cnt > n) break;
if (n%cnt == 0)
{
printf("%d\n", i);
for (LL k = j; k < j + i; k++) printf("%d%s", k, k + 1 == j + i ? "\n" : "*");
return 0;
}
}
}
for (LL i = 2; i*i <= n; i++) if (n%i == 0) {
printf("1\n%d\n", i); return 0;
}
printf("1\n%d\n", n);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT