您的位置:首页 > 其它

HDU 1213 How Many Tables(并查集)

2016-03-25 16:48 411 查看


How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 21794    Accepted Submission(s): 10800



Problem Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do
not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.


 


Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends
are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.


 


Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.


 


Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5


 


Sample Output

2
4


 

思路:并查集的模板题。

代码如下:#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
int father[1005];
void initset(int n){//初始化father数组
for(int i=1;i<=n;i++){
father[i]=i;
}
}
int findset(int i){//递归求该结点的祖先
if(i!=father[i]){
father[i]=findset(father[i]);
}
return father[i];
}
void unionset(int x,int y){//将两个点连起来
int a=findset(x);
int b=findset(y);
if(a==b)return;
else father[b]=a;
}
int main(){
int cases,i,j,n,m,x,y,cnt;
cin>>cases;
while(cases--){
cnt=0;
cin>>n>>m;
initset(n);
for(i=1;i<=m;i++){
cin>>x>>y;
unionset(x,y);
}
for(i=1;i<=n;i++){
if(father[i] == i)cnt++;//father[i]==i说明该结点的祖先就是自己,即这是一棵树的根
}
cout<<cnt<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  并查集