您的位置:首页 > 其它

HDU 2717Catch That Cow

2016-03-24 21:32 127 查看

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 11019    Accepted Submission(s): 3429


[align=left]Problem Description[/align]
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer
John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

[align=left]Input[/align]
Line 1: Two space-separated integers: N and K
 

[align=left]Output[/align]
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

[align=left]Sample Input[/align]

5 17

 

[align=left]Sample Output[/align]

4

HintThe fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

 

[align=left]Source[/align]
USACO 2007 Open Silver

 

[align=left]Recommend[/align]
teddy   |   We have carefully selected several similar problems for you:  2102 1372 1240 1072 1180 
用广搜把所有走法遍历一遍
#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
#define max 100010
using namespace std;
int step[2*max];
void bfs(int n,int m)
{
int now,next,i;
memset(step,0,sizeof(step));
queue<int>q;
q.push(n);
while(!q.empty())
{
now=q.front();
q.pop();
if(now==m)
break;
for(i=0;i<3;i++)
{
if(i==0)
next=now+1;
if(i==1)
next=now-1;
if(i==2)
next=now*2;
if(next>=0&&next<max&&!step[next])
{
step[next]=step[now]+1;
q.push(next);
}
}
}
}
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)!=EOF)
{
bfs(n,m);
printf("%d\n",step[m]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: