您的位置:首页 > 其它

hdu 2824 The Euler function

2016-03-24 19:59 316 查看

The Euler function

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5028 Accepted Submission(s): 2123


[align=left]Problem Description[/align]
The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)

[align=left]Input[/align]
There are several test cases. Each line has two integers a, b (2<a<b<3000000).

[align=left]Output[/align]
Output the result of (a)+ (a+1)+....+ (b)

[align=left]Sample Input[/align]

3 100

[align=left]Sample Output[/align]

3042
题意:求a到b之间的每个数的欧拉函数的和

#include<stdio.h>
#include<string.h>
#include<cstdio>
#include<string>
#include<math.h>
#include<algorithm>
#define LL long long
#define PI atan(1.0)*4
#define DD double
#define MAX 3000010
#define mod 100
#define dian 1.000000011
#define INF 0x3f3f3f
using namespace std;
LL s[MAX],a[MAX];
void el()
{
LL i,j;
for(i=2;i<MAX;i++)
{
if(!a[i])
{
for(j=i;j<MAX;j+=i)
{
if(!a[j]) a[j]=j;
a[j]=a[j]/i*(i-1);
}
}
a[i]+=a[i-1];
}
}
int main()
{
LL n,m,j,i,t;
el();
while(scanf("%lld%lld",&n,&m)!=EOF)
{
t=a[m]-a[n-1];
printf("%lld\n",t);
}
return 0;
}


  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: