您的位置:首页 > 其它

2012年浙大:Hello World for U

2016-03-24 19:44 525 查看
题目描述:
Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h d
e l
l r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

输入:
There are multiple test cases.Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

输出:
For each test case, print the input string in the shape of U as specified in the description.

样例输入:
helloworld!
ac.jobdu.com

样例输出:
h   !
e   d
l   l
lowor
a    m
c    o
.    c
jobdu.

题目来源:http://ac.jobdu.com/problem.php?pid=1464


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char s[100];
int main()
{
while(scanf("%s",s)!=EOF)//gets WA
{
int len=strlen(s);
int n1=max(min((len-1)/2,(len+2)/3),1);
n1--;
int n2=len-n1*2;
for(int i=0;i<n1;i++)
{
printf("%c",s[i]);
for(int j=0;j<n2-2;j++)
{
printf(" ");
}
printf("%c\n",s[len-i-1]);
}
for(int i=n1;i<len-n1;i++)
{
printf("%c",s[i]);
}
printf("\n");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: