您的位置:首页 > 其它

HDU 3746 Cyclic Nacklace (KMP求循环结)

2016-03-24 17:53 561 查看
Cyclic Nacklace
Crawling in process...
Crawling failed
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d
& %I64u

Submit

Status


Description

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about
how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful
decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with
colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost
pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:







Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that
is to say, adding to the middle is forbidden.

CC is satisfied with his ideas and ask you for help.

 

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.

Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000
).

 

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.

 

Sample Input

3
aaa
abca
abcde


 

Sample Output

0
2
5


思路:根据KMP算法求字符串的next值,然后字符串长度len-next[len-1]就是一个周期的长度。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char p[100005];
int Next[100005];
void makeNext(){
int q,k,len;
len=strlen(p);
for(q=1,k=0;q<len;q++){
while(k > 0 && p[q] != p[k]){
k=Next[k-1];
}
if(p[q] == p[k]){
k++;
}
Next[q]=k;
}
}
int main(){
int cases,i,j,len1,len2;
cin>>cases;
while(cases--){
scanf("%s",p);
makeNext();
len1=strlen(p);
len2=Next[len1-1];
if(len1 != len1-len2 && len1 %(len1-len2) == 0){//如果满足刚好有大于等于2个周期
cout<<0<<endl;
}
else{//不满足
cout<<len1-len2-len1%(len1-len2)<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  kmp