您的位置:首页 > 其它

ZOJ3609——数论基础 扩展欧几里得求解乘法逆元

2016-03-24 13:11 351 查看
原题如下:

Description

The modular modular multiplicative inverse of an integer a modulo m is an integer x such that 
a-1≡x (mod m)
. This is equivalent to
ax≡1 (mod m)
.

Input

There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases.

Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.

Output

For each test case, output the smallest positive x. If such x doesn't exist, output "Not Exist".

Sample Input

3
3 11
4 12
5 13


Sample Output

4
Not Exist
8


题目大意:裸的求模的乘法逆元的题目,要注意得有要是正解。所以若解为负的,得加上解得间隔直到解为正数。间隔为m/gcd(a,m)。

代码如下

#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <cctype>
#include <queue>
using namespace std;
//欧几里得算法
int gcd(int a,int b)
{
if(b==0)
return a;
return gcd(b,a%b);
}
//扩展欧几里得算法
int exgcd(int a,int b,int &x,int &y)
{
int d=a;
if(b!=0)
{
d=exgcd(b,a%b,y,x);
y-=(a/b)*x;
}
else
{
x=1;
y=0;
}
return d;
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int a,m;
scanf("%d%d",&a,&m);
if(gcd(a,m)!=1)//如果最大公因数不是1,则表明无解
{
printf("Not Exist\n");
continue;
}
int x,y;
exgcd(a,m,x,y);
while(x<=0)
{
x+=m/gcd(a,m);//使结果为正数
}
printf("%d\n",x);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: