您的位置:首页 > 其它

HDU:1060 Leftmost Digit(数学)(水)

2016-03-23 22:47 495 查看


Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 15848    Accepted Submission(s): 6182


Problem Description

Given a positive integer N, you should output the leftmost digit of N^N.

 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).

 

Output

For each test case, you should output the leftmost digit of N^N.

 

Sample Input

2
3
4

 

Sample Output

2
2

Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.

 

Author

Ignatius.L

 

题目大意:给你一个数字n,求n^n的结果的最左边的数字。

解题思路:m=n^n;两边同取对数,得到,log10(m)=n*log10(n);再得到,m=10^(n*log10(n));

然后,对于10的整数次幂,仅控制结果的小数点位置,所以,第一位数取决于n*log10(n)的小数部分

总之,log很强大啊,在求一个数的位数上,在将大整数化成范围内的整数上。

相关知识点连接:点击打开链接

#include <stdio.h>
#include <math.h>
int main()
{
int t;
scanf("%d\n",&t);
while(t--)
{
double n;
scanf("%lf",&n);
double w=n*log10(n);
double q=w-(long long)w;
double p=pow(10,q);
int a=(int)p;
printf("%d\n",a);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  水题 数学知识