您的位置:首页 > 其它

hdu 1677 Nested Dolls

2016-03-23 22:38 281 查看
Problem Description

Dilworth is the world’s most prominent collector of Russian nested dolls: he literally has thousands of them! You know, the wooden hollow dolls of different sizes of which the smallest doll is contained in the second smallest, and this doll is in turn contained in the next one and so forth. One day he wonders if there is another way of nesting them so he will end up with fewer nested dolls? After all, that would make his collection even more magnificent! He unpacks each nested doll and measures the width and height of each contained doll. A doll with width w1 and height h1 will fit in another doll of width w2 and height h2 if and only if w1 < w2 and h1 < h2. Can you help him calculate the smallest number of nested dolls possible to assemble from his massive list of measurements?

Input

On the first line of input is a single positive integer 1 <= t <= 20 specifying the number of test cases to follow. Each test case begins with a positive integer 1 <= m <= 20000 on a line of itself telling the number of dolls in the test case. Next follow 2m positive integers w1, h1,w2, h2, … ,wm, hm, where wi is the width and hi is the height of doll number i. 1 <= wi, hi <= 10000 for all i.

Output

For each test case there should be one line of output containing the minimum number of nested dolls possible.

Sample Input

4

3

20 30 40 50 30 40

4

20 30 10 10 30 20 40 50

3

10 30 20 20 30 10

4

10 10 20 30 40 50 39 51

Sample Output

1

2

3

2

分析:用贪心做,大的套小的,排个序,然后一直套下去。但是开始用w升序,h也升序,wa了。但是把 w相同时,h降序就对了,实在不知道为什么!也看了网友博客,测试了数据,能过!本人实在找不出反例。还是年轻了!

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int vis[20001];
int cnt;
struct tw
{
int wi;
int hi;
}taowa[20001];
bool Cmp1(tw s1, tw s2)
{
if (s1.wi != s2.wi) return s1.wi < s2.wi;
else    return s1.hi> s2.hi;
}
int zz()
{
int sum=0;
int i,j;
int maxw,maxh;
for(i=0;i<cnt;i++)
{
if(vis[i]==0)//没有被套过,从它开始计算
{
sum++;
vis[i]=1;
maxw=taowa[i].wi;
maxh=taowa[i].hi;
for(j=i+1;j<cnt;j++)
{
if(vis[j]==0)//能套它
{
if(taowa[j].wi>maxw  &&  taowa[j].hi>maxh  )
{
vis[j]=1;//标记更新
maxw=taowa[j].wi;
maxh=taowa[j].hi;
}
}
}
}
}
return sum;
}
int main()
{
int n;
int i,j,mi;
scanf("%d",&n);
while(n--)
{    memset(vis,0,sizeof(vis));
scanf("%d",&cnt);
for(i=0;i<cnt;i++)
scanf("%d %d",&taowa[i].wi,&taowa[i].hi);
sort(taowa, taowa + cnt, Cmp1);
mi= zz();
printf("%d\n",mi);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: