您的位置:首页 > 其它

HDU-2602-Bone Collector

2016-03-23 21:31 381 查看
Bone Collector

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 45832 Accepted Submission(s): 19075

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input

The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input

1

5 10

1 2 3 4 5

5 4 3 2 1

Sample Output

14

01背包 动规基础题

状态转移方程:dp[j]=max(dp[j],dp[j-num[i].体积]+num[i].价值

代码

#include<iostream>
#include<algorithm>
#include<math.h>
#include<string>
#include<string.h>
#include<stdio.h>
#include<queue>
using namespace std;
//01背包
struct node
{
int value;//价值
int volume;//体积
} num[1005];
int dp[1005];
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
memset(dp,0,sizeof(dp));
int N;//数量
int max_v;//背包最大体积
scanf("%d%d",&N,&max_v);
for(int i=0; i<N; i++)
scanf("%d",&num[i].value);
for(int i=0; i<N; i++)
scanf("%d",&num[i].volume);
for(int i=0; i<N; i++)
{
for(int j=max_v; j>=num[i].volume; j--)
{
dp[j]=max(dp[j],dp[j-num[i].volume]+num[i].value);
}
}
printf("%d\n",dp[max_v]);
}
return 0;
}


背包 背包 背包
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: