您的位置:首页 > 其它

hdu 1312 Red and Black

2016-03-23 20:27 357 查看
[align=left]Problem Description[/align]
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

[align=left]Input[/align]
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

[align=left]Output[/align]
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

[align=left]Sample Input[/align]

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

[align=left]Sample Output[/align]

45
59
6
13

#include <iostream>

using namespace std;
int x,y,k,t;
char data[25][25];

int f(int i,int j)
{
if(i<1||i>y||j<1||j>x)//处理边界问题
return 0;
if(data[i][j]!='#')
{
data[i][j]='#';
return 1+f(i-1,j)+f(i+1,j)+f(i,j-1)+f(i,j+1);
}
else//上/下/左/右/不能走了
return 0;
}

int main()
{
while(cin>>x>>y)
{
if(x==0&&y==0) break;
k=-1;t=-1;
for(int i=1;i<=y;i++)
{
for(int j=1;j<=x;j++)
{
cin>>data[i][j];
if(data[i][j]=='@')
{
k=i;t=j;
}
}
}
cout<<f(k,t)<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: