您的位置:首页 > 其它

hdu 2795 Billboard

2016-03-23 17:02 405 查看

Billboard

Time Limit: 20000/8000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17256 Accepted Submission(s):
7291


[align=left]Problem Description[/align]
At the entrance to the university, there is a huge
rectangular billboard of size h*w (h is its height and w is its width). The
board is the place where all possible announcements are posted: nearest
programming competitions, changes in the dining room menu, and other important
information.

On September 1, the billboard was empty. One by one, the
announcements started being put on the billboard.

Each announcement is a
stripe of paper of unit height. More specifically, the i-th announcement is a
rectangle of size 1 * wi.

When someone puts a new announcement on the
billboard, she would always choose the topmost possible position for the
announcement. Among all possible topmost positions she would always choose the
leftmost one.

If there is no valid location for a new announcement, it is
not put on the billboard (that's why some programming contests have no
participants from this university).

Given the sizes of the billboard and
the announcements, your task is to find the numbers of rows in which the
announcements are placed.

[align=left]Input[/align]
There are multiple cases (no more than 40
cases).

The first line of the input file contains three integer numbers,
h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions
of the billboard and the number of announcements.

Each of the next n
lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th
announcement.

[align=left]Output[/align]
For each announcement (in the order they are given in
the input file) output one number - the number of the row in which this
announcement is placed. Rows are numbered from 1 to h, starting with the top
row. If an announcement can't be put on the billboard, output "-1" for this
announcement.

[align=left]Sample Input[/align]

3 5 5

2

4

3

3

3

[align=left]Sample Output[/align]

1

2

1

3

-1

[align=left]Author[/align]
hhanger@zju

[align=left]Source[/align]
HDOJ
2009 Summer Exercise(5)

[align=left]Recommend[/align]
lcy | We have carefully selected several similar
problems for you: 1698 1542 1828 1540 1255

又一次写线段树的题目,还是看了别人的博客,感觉受益良多。
首先,叶子节点只有min(n, h)个,不要被10^9吓到;然后把每行的空间存进树,每贴一条广告就删除相应的空间。

题意:一块h*w的广告板上贴广告,每条广告均为1*wi;如果能贴,输出贴的位置(即第几行,位置尽量靠上,靠左);否则输出-1。

附上代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#define M 200010
using namespace std;
struct node
{
int l,r,s;
} ss[M*4];

int w,h,n;

int max(int a,int b)
{
return a>b?a:b;
}
void build(int l,int r,int k)
{
ss[k].l=l;
ss[k].r=r;
ss[k].s=w;
if(l==r) return;
int mid=(ss[k].l+ss[k].r)/2;
build(l,mid,2*k);
build(mid+1,r,2*k+1);
}

int search(int x,int k)
{
if(ss[k].l==ss[k].r)
{
ss[k].s -= x;    //找到一个便减去对应的空间
return ss[k].l;
}
else
{
int sum1=0, sum2=0;
if(x <= ss[k*2].s) sum1 = search(x,k*2);      //如果左子树够用,则进入左子树,否则进入右子树
else if(x <= ss[k*2+1].s) sum2 = search(x,k*2+1);
ss[k].s = max(ss[k*2].s,ss[k*2+1].s);         //根节点保存子树中大的值
return sum1+sum2;
}
}

int main()
{
int i,j,k;
while(~scanf("%d%d%d",&h,&w,&n))
{
if(h>n) h=n;
build(1,h,1);
for(i=1; i<=n; i++)
{
scanf("%d",&k);
if(k <= ss[1].s) printf("%d\n",search(k,1));
else printf("-1\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: