您的位置:首页 > 其它

HDU 2602 Bone Collector

2016-03-23 14:05 302 查看


Bone Collector

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 45816 Accepted Submission(s): 19072



Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?



Input

The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1


Sample Output

14


Author

Teddy

Source

HDU 1st “Vegetable-Birds Cup” Programming
Open Contest

简单01背包问题,这些都一个解法,用一维的效率好很多。

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
const int MAXN=1005;
const int MAXV=1005;
int value[MAXN],weight[MAXN];
int dp[MAXV];
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int N,V;
scanf("%d%d",&N,&V);
memset(dp,0,sizeof(dp));
for(int i=0;i<N;i++)
scanf("%d",&value[i]);
for(int i=0;i<N;i++)
scanf("%d",&weight[i]);
for(int i=0;i<N;i++)
for(int j=V;j>=weight[i];j--)
dp[j]=max(dp[j],dp[j-weight[i]]+value[i]);
printf("%d\n",dp[V]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: