您的位置:首页 > 其它

hdu5137How Many Maos Does the Guanxi Worth【最短路最大值】

2016-03-22 09:32 423 查看
[align=left]Problem Description[/align]
"Guanxi" is a very important word in Chinese. It kind of means "relationship" or "contact". Guanxi can be based on friendship, but also can be built on money. So Chinese often say "I don't have one mao (0.1 RMB) guanxi with you."
or "The guanxi between them is naked money guanxi." It is said that the Chinese society is a guanxi society, so you can see guanxi plays a very important role in many things.

Here is an example. In many cities in China, the government prohibit the middle school entrance examinations in order to relief studying burden of primary school students. Because there is no clear and strict standard of entrance, someone may make their children
enter good middle schools through guanxis. Boss Liu wants to send his kid to a middle school by guanxi this year. So he find out his guanxi net. Boss Liu's guanxi net consists of N people including Boss Liu and the schoolmaster. In this net, two persons who
has a guanxi between them can help each other. Because Boss Liu is a big money(In Chinese English, A "big money" means one who has a lot of money) and has little friends, his guanxi net is a naked money guanxi net -- it means that if there is a guanxi between
A and B and A helps B, A must get paid. Through his guanxi net, Boss Liu may ask A to help him, then A may ask B for help, and then B may ask C for help ...... If the request finally reaches the schoolmaster, Boss Liu's kid will be accepted by the middle school.
Of course, all helpers including the schoolmaster are paid by Boss Liu.

You hate Boss Liu and you want to undermine Boss Liu's plan. All you can do is to persuade ONE person in Boss Liu's guanxi net to reject any request. This person can be any one, but can't be Boss Liu or the schoolmaster. If you can't make Boss Liu fail, you
want Boss Liu to spend as much money as possible. You should figure out that after you have done your best, how much at least must Boss Liu spend to get what he wants. Please note that if you do nothing, Boss Liu will definitely succeed.
 

[align=left]Input[/align]
There are several test cases.

For each test case:

The first line contains two integers N and M. N means that there are N people in Boss Liu's guanxi net. They are numbered from 1 to N. Boss Liu is No. 1 and the schoolmaster is No. N. M means that there are M guanxis in Boss Liu's guanxi net. (3 <=N <= 30,
3 <= M <= 1000)

Then M lines follow. Each line contains three integers A, B and C, meaning that there is a guanxi between A and B, and if A asks B or B asks A for help, the helper will be paid C RMB by Boss Liu.

The input ends with N = 0 and M = 0.

It's guaranteed that Boss Liu's request can reach the schoolmaster if you do not try to undermine his plan.
 

[align=left]Output[/align]
For each test case, output the minimum money Boss Liu has to spend after you have done your best. If Boss Liu will fail to send his kid to the middle school, print "Inf" instead.
 

[align=left]Sample Input[/align]

4 5
1 2 3
1 3 7
1 4 50
2 3 4
3 4 2
3 2
1 2 30
2 3 10
0 0

 

[align=left]Sample Output[/align]

50
Inf

 

[align=left]Source[/align]
2014ACM/ICPC亚洲区广州站-重现赛(感谢华工和北大)

题意:暴发户给孩子办关系升学,需要一个人找一个人,人情钱都是这货出,你要劝说其中一个人不去帮忙使得暴发户花钱最多。

又tm读错题了,你是劝说一个人使得他不去帮忙,而不是单纯的只使一个边变成inf!是与这个人相连的边都变成inf!还有就是虽说你想让这个人花钱最多,但是人家又不傻,当然会选择”最短路“来花钱!再有,总共30个点,枚举一遍怎么会超时,有什么不敢写的。脑子绝对是坏掉了==

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=33;
const int inf=0x3f3f3f3f;
bool vis[maxn];
int pre[maxn],lowcost[maxn],cost[maxn][maxn];
void dijkstra(int n,int beg)
{
for(int i=0;i<n;i++)
{
lowcost[i]=inf;vis[i]=false;pre[i]=-1;
}
lowcost[beg]=0;
for(int j=0;j<n;j++)
{
int k=-1;
int Min=inf;
for(int i=0;i<n;i++)
if(!vis[i]&&lowcost[i]<Min)
{
Min=lowcost[i];
k=i;
}
if(k==-1)break;
vis[k]=true;
for(int i=0;i<n;i++)
if(!vis[i]&&lowcost[k]+cost[k][i]<lowcost[i])
{
lowcost[i]=lowcost[k]+cost[k][i];
pre[i]=k;
}
}
}
int temp[maxn];
int main()
{
// freopen("cin.txt","r",stdin);
int n,m;
while(~scanf("%d%d",&n,&m)&&n&&m)
{
memset(cost,inf,sizeof(cost));
for(int i=0;i<m;i++)
{
int a,b,c;
scanf("%d%d%d",&a,&b,&c);
a--;b--;
if(c>cost[a][b]) continue;
cost[a][b]=cost[b][a]=c;
}
int ans=0;

for(int i=1;i<n-1;i++)
{
for(int j=0;j<=n-1;j++)
{
temp[j]=cost[i][j];
cost[i][j]=cost[j][i]=inf;
}
dijkstra(n,0);
if(lowcost[n-1]>ans) ans=lowcost[n-1];
for(int j=0;j<n;j++)
cost[i][j]=cost[j][i]=temp[j];
}
if(ans<inf) printf("%d\n",ans);
else printf("Inf\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: