您的位置:首页 > 其它

poj 2393 Yogurt factory

2016-03-22 08:37 309 查看
问题描述

The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000)
cents to produce one unit of yogurt in week i. Yucky's factory, being well-designed, can produce arbitrarily many units of yogurt each week.

Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt's warehouse is enormous, so it can hold arbitrarily many units of yogurt.

Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any
yogurt already in storage, can be used to meet Yucky's demand for that week.

输入

* Line 1: Two space-separated integers, N and S.

* Lines 2..N+1: Line i+1 contains two space-separated integers: C_i and Y_i.

输出

* Line 1: Line 1 contains a single integer: the minimum total cost to satisfy the yogurt schedule. Note that the total might be too large for a 32-bit integer.

样例输入

4 5
88 200
89 400
97 300
91 500


样例输出

126900


简单的贪心,每周有两种情况,要么是自己生产,要么是用上一周存下来的(只能是上一周,不能使上上周,因为每次都取最优,如果你取上上周比取上周还优,那只能说明你上周都没取好),所以只需要比较这两者的大小取最小值即可。

#include <iostream>
#include <cstdio>
using namespace std;

int main()
{
int N,S;long long sum=0;
scanf("%d%d",&N,&S);
int minn=88888888;
while(N--)
{
int c,y;
scanf("%d%d",&c,&y);
c=min(minn+S,c);
minn=c;
sum+=c*y;
}
printf("%lld\n",sum);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: