您的位置:首页 > 其它

SDAU 贪心专题 13 盈利问题

2016-03-21 22:52 246 查看
1:问题描述

Problem Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.

All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input

59 237

375 743

200000 849694

2500000 8000000

Sample Output

116

28

300612

Deficit

2:大致题意

将一年分为:

1—5月。2—6月。3—7月。4—8月。5—9月。

6—10月。7—11月。8—12月。

输入两个数据n,m分别代表一个月盈利的钱数和亏本的钱数。

要使上述几个区间都亏本。求出这一年能赚最多的钱。

3:思路

肯定要找重叠比较多的月份,这样就可以让亏本的月份尽可能的少。

(1)如果4*n< m 那么让5月和10月亏本。那么1—5月。2—6月。3—7月。4—8月。5—9月。都是亏的。一年亏2个月。赚10个月。

(2)如果3*n< m那么就让5月,4月,10月,9月亏钱。一年亏4个月赚8个月。

(3)依次类推。将5种情况全写出来。直接求盈利的钱数就行了。

4:感想

找重叠点不怎么好找呀。慢慢来o(^▽^)o

都11点了,再写2个就睡觉。

5:ac代码

#include <cstdio>
#include<iostream>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<map>
#include<set>
#include<vector>
#include<iomanip>
using namespace std;
int main()
{
int n,m,z;
while(cin>>n)
{
cin>>m;
if(n*4<m) z=n*10-2*m;
else if(n*3<2*m) z=n*8-4*m;
else if(n*2<3*m) z=n*6-m*6;
else if(n<4*m)  z=n*3-m*9;
else z=-1;
if(z<0)  cout<<"Deficit"<<endl;
else cout<<z<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm