您的位置:首页 > 其它

Poj 1017 Packets【贪心+细节】

2016-03-21 21:40 393 查看
Packets

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 49569 Accepted: 16769
Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because
of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels
necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.
Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest
size 6*6. The end of the input file is indicated by the line containing six zeros.
Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last
``null'' line of the input file.
Sample Input
0 0 4 0 0 1
7 5 1 0 0 0
0 0 0 0 0 0

Sample Output
2
1


题意:
给出1*1,2*2.....6*6 的方块(高度不考虑),全部放入6*6的箱子中,问最少需要多少个箱子。

题解:

题目给出不需要考虑高度的情况了,然后就是面积,然后就比较复杂了.....

1,先考虑大的,对于4*4,5*5,6*6 的方块,必定每个占用一个箱子,对于3*3的,每四个正好占用一个箱子

2,考虑放2*2的方块,统计出之前用过的箱子有多少位置能放2*2的方块,注意方块数量可能不够

3,考虑放1*1的方块,也就是箱子中剩下的所有空间了!放入1*1的方块(注意点同上一步)

4,剩余的1*1 和2*2 的直接统计面积,看额外至少需要多少个箱子

详细解释见代码。

个人本来想找个非常好的方法直接进行模拟,.结果失败了......

后来实在没办法,还是最直接的贪心枚举六种的情况吧......

竟然还是WA!!后来才发现,原来是跳出主程序的语句没控制好...........

/* http://blog.csdn.net/liuke19950717 */
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
typedef long long ll;
ll tab[]={0,5,3,1};//tab[i]表示放i个3*3的,还能放多少2*2的
ll slove(ll x[])
{
ll num3=ceil(x[3]/4.0);//3*3的必须使用的盒子数量
ll ans=x[6]+x[5]+x[4]+num3;//不包括1*1和2*2 时必须使用的盒子的数量
ll num2=5*x[4]+tab[x[3]%4];//统计能放2*2的个数
num2=min(num2,x[2]); //计算能使用的2*2的方块最大数量
x[2]-=num2;//2*2的方格使用掉
ll rest=36*ans-x[6]*36-x[5]*25-x[4]*16-x[3]*9-num2*4;//剩余位置
rest=min(rest,x[1]);//能使用1*1的最大数量
x[1]-=rest;//使用1*1的方块
rest=x[2]*4+x[1];//看是否有剩余,有的话,单独找个大箱子
return ans+ceil(rest/36.0);
}
int main()
{
ll x[10];
//freopen("shuju.txt ","r",stdin);
while(~scanf("%lld",&x[1]))
{
int kase=x[1];//坑了我一次WA,自己思维不够严谨
for(ll i=2;i<=6;++i)
{
scanf("%lld",&x[i]);
if(x[i])
{
kase=1;
}
}
if(!kase)//全为零结束
{
break;
}
printf("%lld\n",slove(x));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: