您的位置:首页 > 其它

贪心 1011

2016-03-21 08:49 441 查看
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance,
so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write
a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.



Figure A Sample Input of Radar Installations

 

[align=left]Input[/align]
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed
by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. <br> <br>The input is terminated by a line containing pair of zeros <br>
 

[align=left]Output[/align]
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
 

[align=left]Sample Input[/align]

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

 

[align=left]Sample Output[/align]

Case 1: 2
Case 2: 1
雷达
区间问题
struct 设立区间
然后贪心比较最后
然后排列前面
逐个缩小
直到缩小没有
找下一个#include <cstdio>
#include<iostream>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<map>
#include<set>
#include<vector>
#include<iomanip>
using namespace std;
struct ww
{
double mix;
double max;
};
bool cmp(const ww &A,const ww &B)
{
if(A.max<=B.max) return true;
return false;
}

int main()
{ double paopao;
int n;
int t;
int s[1000];
int aa=0;
ww l[1000];
while(cin>>n>>t&&t!=0||n!=0)
{ aa=aa+1;
double a;
double b;
memset(s,0,sizeof(s));

int i;
int flag=0;
for(i=1;i<=n;i++)
{
cin>>a;
cin>>b;
paopao=sqrt(t*t-b*b);
l[i].mix=a-paopao;
l[i].max=a+paopao;
if(b>t)
flag=1;
}

if(flag==1)
cout<<"Case "<<aa<<": "<<"-1"<<endl;
else
{
sort(l+1,l+n+1,cmp);
int xx=n;
int sum=1;
for(i=n-1;i>=1;i--)
{
if(l[i].max<l[xx].mix)
{
sum++;
xx=i;
}
else if(l[i].mix>=l[xx].mix)
{ xx=i;
}
}

cout<<"Case "<<aa<<": "<<sum<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: