您的位置:首页 > 其它

[1194]:Beat the Spread!

2016-03-20 02:08 405 查看
Problem Description

Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two final scores, or on the absolute difference(差的绝对值) between the two scores.

Given the winning numbers for each type of bet, can you deduce the final scores?

Input

The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final scores.(给出两数和和两数差的绝对值,求两数)

Output

For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing “impossible”. Recall that football scores are always non-negative integers.

Sample Input

2

40 20

20 40

Sample Output

30 10

impossible

只要看懂了题意,就可以做

#include<stdio.h>

int main()
{
int n, s, d, max, min;
while(scanf("%d", &n)!=EOF){
while(n--){
scanf("%d%d", &s, &d);
if((s+d)%2==1 || d>s){
printf("impossible\n");
continue;
} else {
max = (s+d)/2;
min = s - max;
}
if(max < min){
int temp = max;
max = min;
min = temp;
}
printf("%d %d\n", max, min);
}
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: