您的位置:首页 > 其它

Power Strings (POJ_2406) KMP + 循环节

2016-03-19 21:37 399 查看
Power Strings

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 40791 Accepted: 16967
Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the
empty string) and a^(n+1) = a*(a^n).
Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output

For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.

Sample Output
1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题目大意:给出一个字符串求问它最多能由几个相同字符串连接而成。

解题思路:KMP求出最小循环节。

代码如下:

#include"iostream"
#include"cstdio"
#include"cstring"
using namespace std;
const int maxn = 1000005;

char str[maxn];
int Next[maxn];

void MakeNext(int m){
Next[0] = -1;
int i = 0,j = -1;
while(i < m){
if(j == -1 || str[i] == str[j])
Next[++i] = ++j;
else
j = Next[j];
}
}

int main(){
int len,length,time;
while(gets(str) != 0){
if(str[0] == '.') break;
len = strlen(str);
MakeNext(len);
length = len - Next[len];//循环节
time = len / length;
if(len % length == 0)
printf("%d\n",time);
else
printf("1\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  KMP 循环节