您的位置:首页 > 其它

POJ 1579/hrbust 1029/哈理工oj 1029 Function Run Fun【记忆化搜索】

2016-03-19 11:19 453 查看
Function Run Fun

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 17757 Accepted: 9071
Description

We all love recursion! Don't we? 

Consider a three-parameter recursive function w(a, b, c): 

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns: 



if a > 20 or b > 20 or c > 20, then w(a, b, c) returns: 

w(20, 20, 20) 

if a < b and b < c, then w(a, b, c) returns: 

w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c) 

otherwise it returns: 

w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1) 

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion. 

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.
Output

Print the value for w(a,b,c) for each triple.
Sample Input
1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output
w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1


题目大意:给你一个递归公式,让你AC..............如果你真的呆萌的直接按照递归敲了,觉得这个题是个很水的递归模拟题,那你就真的年轻了,试着按照题干说的输入 15 15 15

你的电脑真的会跑上好几个小时。。。。。。。。。。。。。。。。。。。。原因很简单,递归的层数深了,操作的次数多了,再怎么快的电脑也扛不住这么大量的数据处理。

所以我们尝试来优化递归的过程,如果小伙伴们足够细心,很容易发现f(a,b,c)是固定的值,而且递归量比较大的时候,我们不难发现很多重复的情况,我们可以在函数开头写这样一句话:if(a==1&&b==2&&c==3)printf("yes\n");【这组数据是随便写的,只要足够小,输出的yes就会足够多】,如果我们记下f(1,2,3)的值,我们就可以避免很多重复的情况,所以我们只需要记录一遍f(a,b,c)的数据就可以轻松的剪掉很多重复的枝条。

AC代码:

#include<stdio.h>
#include<string.h>
using namespace std;
int dp[25][25][25];
int f(int a,int b,int c)
{
if(a<=0||b<=0||c<=0)return 1;
else if(a>20||b>20||c>20)return f(20,20,20);
if(dp[a][b][c])return dp[a][b][c];
else if(a<b&&b<c)
{
dp[a][b][c]=f(a,b,c-1)+f(a,b-1,c-1)-f(a,b-1,c);
return dp[a][b][c];
}
else
{
dp[a][b][c]=f(a-1,b,c)+f(a-1,b-1,c)+f(a-1,b,c-1)-f(a-1,b-1,c-1);
return dp[a][b][c];
}
}
int main()
{
memset(dp,0,sizeof(dp));
int a,b,c;
while(~scanf("%d%d%d",&a,&b,&c))
{
if(a==-1&&b==-1&&c==-1)break;
printf("w(%d, %d, %d) = %d\n",a,b,c,f(a,b,c));
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  POJ 1579