您的位置:首页 > 其它

poj2253

2016-03-19 09:16 411 查看
B - Frogger
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d
& %I64u
Submit Status Practice POJ
2253

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her
by jumping. 

Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 

To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 

The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's
stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line
after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0


Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题意:在一个池塘里,有一些露出水面的石头,A青蛙要通过跳跃到B青蛙那里去,N表示有N-2个石头,下面N行,第一行表示青蛙A坐标,第二行表示青蛙B坐标,第3~N行表示石头坐标,青蛙A希望走短路径到到青蛙B,问青蛙A最短的跳跃距离,
其实就是求最短路径上最长的一条路;
套用模板轻松搞定:
#include <iostream>
#include <queue>
#include <stdio.h>
#include <string.h>
#include <math.h>
using namespace std;
struct edge
{
double x,y;
} d[205];
const double inf=1e9*1.0;
double fd(edge a,edge b)
{
return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double map[202][202];
int main()
{
int n;
int tot=1;
bool used[205];
double cost[202];
while(cin>>n)
{
memset(used,false,sizeof(used));
if(n==0)
break;
for(int i=1; i<=n; i++)
cin>>d[i].x>>d[i].y;
for(int i=1; i<=n; i++)
{
for(int j=1; j<=n; j++)
map[i][j]=fd(d[i],d[j]);
}
used[1]=true;
double ans=-inf;
for(int i=1; i<=n; i++)
cost[i]=map[1][i];///集合cost
for(int i=1; i<n; i++)
{
double minc=inf;
int k=-1;
for(int j=1; j<=n; j++)
{
if(!used[j]&&minc>cost[j])
{
minc=cost[j];
k=j;
}
}
ans=max(ans,minc);
used[k]=true;
if(k==2)
break;
for(int j=1; j<=n; j++)
{
if(map[k][j]<cost[j]&&!used[j])
{
cost[j]=map[k][j];
}
}
}
printf("Scenario #%d\n",tot++);
printf("Frog Distance = %.3f\n\n",ans);
}
// cout << "Hello world!" << endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: