您的位置:首页 > 其它

1083. List Grades (25)【水题】——PAT (Advanced Level) Practise

2016-03-19 00:40 537 查看

题目信息

1083. List Grades (25)

时间限制400 ms

内存限制65536 kB

代码长度限制16000 B

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:

N

name[1] ID[1] grade[1]

name[2] ID[2] grade[2]

… …

name
ID
grade

grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade’s interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student’s name and ID, separated by one space. If there is no student’s grade in that interval, output “NONE” instead.

Sample Input 1:

4

Tom CS000001 59

Joe Math990112 89

Mike CS991301 100

Mary EE990830 95

60 100

Sample Output 1:

Mike CS991301

Mary EE990830

Joe Math990112

Sample Input 2:

2

Jean AA980920 60

Ann CS01 80

90 95

Sample Output 2:

NONE

解题思路

排序

AC代码

#include <iostream>
#include <map>
using namespace std;
int main()
{
ios::sync_with_stdio(false);
cin.tie(0);
int n, a, L, R;
string s1, s2;
map<int, pair<string, string> > mp;
cin >> n;
while(n--){
cin >> s1 >> s2 >> a;
mp[a] = make_pair(s1, s2);
}
cin >> L >> R;
bool flag = false;
for (map<int, pair<string, string> >::reverse_iterator it = mp.rbegin(); it != mp.rend(); ++it){
if (it->first >= L && it->first <= R){
cout <<it->second.first <<" " <<it->second.second <<endl;
flag = true;
}
}
if (!flag) cout <<"NONE" <<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: