您的位置:首页 > 其它

poj 2488 A Knight's Journey

2016-03-18 23:39 330 查看
A Knight's Journey

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 38317Accepted: 13004
Description


Background

The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey

around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board,
but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem

Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents
a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares
of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.

If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3

Sample Output
Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source
TUD Programming Contest 2005, Darmstadt, Germany

这道题有不少需要注意的地方;
首先注意字母表示的是列号,数字表示的是行号;
因为要按照字典序输出,注意搜索的顺序;
找到答案后,立即退出,小心覆盖答案;

#include<iostream>
#include<cstdlib>
#include<string>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<stack>
#include<queue>
#include<iomanip>
#include<map>
#include<set>
#include<functional>
#define pi 3.14159265358979323846
using namespace std;
int p,q;
int len;
struct Point
{
int x;
int y;
}point[100];
bool vis[30][30];
bool flag=0;
int dx[]={-1,1,-2,2,-2,2,-1,1};
int dy[]={-2,-2,-1,-1,1,1,2,2};
void dfs(int x,int y)
{
if(len==p*q)
{
flag=1;
//cout<<'A'<<endl;
return ;
}
for(int i=0;i<8;++i)
{
int tx=x+dx[i];
int ty=y+dy[i];
if(tx>=0&&tx<p&&ty>=0&&ty<q&&vis[tx][ty]!=1)
{
vis[tx][ty]=1;
point[len].x=tx;
point[len].y=ty;
++len;
/*for(int j=0;j<p*q;++j)
{
printf("%d%d ",point[j].x,point[j].y);
}
printf("\n");
cout<<len<<" "<<flag;
printf("\n");*/
dfs(tx,ty);
if(len==p*q)
{
flag=1;
//cout<<'B'<<endl;
return;
}
--len;
vis[tx][ty]=0;
}
}
}
int main()
{
int n;
scanf("%d",&n);
int cnt=0;
while(n--)
{
len=0;
++cnt;
flag=0;
memset(vis,0,sizeof(vis));
scanf("%d %d",&p,&q);
point[0].x=0;
point[0].y=0;
vis[0][0]=1;
++len;
dfs(0,0);
printf("Scenario #%d:\n",cnt);
if(flag==0)
printf("impossible");
else
{
for(int i=0;i<p*q;++i)
printf("%c%d",(point[i].y+'A'),(point[i].x+1));
}
printf("\n\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: