您的位置:首页 > 其它

poj-1961-Period

2016-03-18 19:59 435 查看

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the

number zero on it.

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3

aaa

12

aabaabaabaab

0

Sample Output

Test case #1

2 2

3 3

Test case #2

2 2

6 2

9 3

12 4

题意:对于一个字符串s,查找长度为i的前缀s’,满足s’=AK,即s’有K个连续的A组成,其中K>1

想做明白这道题,需要先看poj 2406

两道题类似,这道题比那道题难一些

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#define N 1000010
using namespace std;
int next
;
char str
;
void kmp_pre(int len){
int i, j;
i = 0;
j = next[0] = -1;
while(i < len){
while(j != -1 && str[i] != str[j])  j = next[j];
next[++i] = ++j;
}
}
int main(){
#ifndef ONLINE_JUDGE
freopen("1.txt", "r", stdin);
#endif
int n, cas = 1, t;
while(scanf("%d", &n)){
if (!n) break;
scanf("%s", str);
kmp_pre(n);
printf("Test case #%d\n", cas++);
for (int i = 1; i <= n; i++){
t = i - next[i];
if (i%t == 0 && i != t){
printf("%d %d\n", i, i/t);
}
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: