您的位置:首页 > 其它

POJ1007.DNA Sorting

2016-03-18 15:14 411 查看
Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is
greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can
be---exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''.
All the strings are of the same length. 

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA


Solution

#include <iostream>
#include <string>
#include <algorithm>
#include <stdio.h>

using namespace std;

typedef struct sortedInfo {
int sortedNum;
int index;
} sortedInfo;

int calculate(string str) {
int count = 0;
for (int i = 0; i < str.size(); i++) {
for (int j = i + 1; j < str.size(); j++) {
if (str[i] > str[j]) {
count++;
}
}
}
return count;
}

bool cmp(sortedInfo a, sortedInfo b) {
return a.sortedNum < b.sortedNum;
}

int main(void) {
string strings[105];
sortedInfo info[105];
int lenOfString, howManyLines;
//freopen("in.txt", "r", stdin);
cin >> lenOfString >> howManyLines;
for (int i = 0; i < howManyLines; i++) {
cin >> strings[i];
info[i].sortedNum = calculate(strings[i]);
info[i].index = i;
}
sort(info, info + howManyLines, cmp);

for (
4000
int i = 0; i < howManyLines; i++) {
cout << strings[info[i].index] << endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: