您的位置:首页 > 其它

【HDU2896】病毒侵袭——AC自动机基础

2016-03-17 20:55 381 查看
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description

当太阳的光辉逐渐被月亮遮蔽,世界失去了光明,大地迎来最黑暗的时刻。。。。在这样的时刻,人们却异常兴奋——我们能在有生之年看到500年一遇的世界奇观,那是多么幸福的事儿啊~~

但网路上总有那么些网站,开始借着民众的好奇心,打着介绍日食的旗号,大肆传播病毒。小t不幸成为受害者之一。小t如此生气,他决定要把世界上所有带病毒的网站都找出来。当然,谁都知道这是不可能的。小t却执意要完成这不能的任务,他说:“子子孙孙无穷匮也!”(愚公后继有人了)。

万事开头难,小t收集了好多病毒的特征码,又收集了一批诡异网站的源码,他想知道这些网站中哪些是有病毒的,又是带了怎样的病毒呢?顺便还想知道他到底收集了多少带病毒的网站。这时候他却不知道何从下手了。所以想请大家帮帮忙。小t又是个急性子哦,所以解决问题越快越好哦~~

Input

第一行,一个整数N(1<=N<=500),表示病毒特征码的个数。

接下来N行,每行表示一个病毒特征码,特征码字符串长度在20—200之间。

每个病毒都有一个编号,依此为1—N。

不同编号的病毒特征码不会相同。

在这之后一行,有一个整数M(1<=M<=1000),表示网站数。

接下来M行,每行表示一个网站源码,源码字符串长度在7000—10000之间。

每个网站都有一个编号,依此为1—M。

以上字符串中字符都是ASCII码可见字符(不包括回车)。

Output

依次按如下格式输出按网站编号从小到大输出,带病毒的网站编号和包含病毒编号,每行一个含毒网站信息。

web 网站编号: 病毒编号 病毒编号 …

冒号后有一个空格,病毒编号按从小到大排列,两个病毒编号之间用一个空格隔开,如果一个网站包含病毒,病毒数不会超过3个。

最后一行输出统计信息,如下格式

total: 带病毒网站数

冒号后有一个空格。

Sample Input

3

aaa

bbb

ccc

2

aaabbbccc

bbaacc

Sample Output

web 1: 1 2 3

total: 1

Source

2009 Multi-University Training Contest 10 - Host by NIT

G++ MLE c++ AC

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
#include <vector>
#include <iostream>
#include <algorithm>

using namespace std;

typedef struct node
{
int Id;

int last;

node *next[100];

node *fail;

node()
{
Id = 0;

last =0;

for(int i = 0;i<100;i++)
{
next[i] = NULL;
}

fail = NULL;
}
}Tree;

char str[10100];

int n,m;

int a[5],top;

void BuildTree(int num,Tree *Root)
{
int len  =strlen(str);

for(int i = 0;i<len;i++)
{
int ans = str[i]-32;

if(Root->next[ans]==NULL) Root->next[ans] = new node();

Root = Root->next[ans];
}

Root->Id = num;
}

void BFS(Tree *Root)
{
queue<Tree*>Q;

Q.push(Root);

Tree *u,*v;

while(!Q.empty())
{
u = Q.front();

Q.pop();

v  = NULL;

for(int i = 0;i<100;i++)
{
if(u->next[i] == NULL) continue;

if(u == Root)
{
u->next[i]->fail = Root;
}
else
{
v = u->fail;

while(v!=NULL)
{
if(v->next[i]==NULL)
{
v = v->fail;
}
else
{
u->next[i]->fail = v->next[i];

break;
}
}

if(v==NULL)
{
u->next[i]->fail = Root;
}
}

Q.push(u->next[i]);
}
}
}

void Query(Tree * Root,int num)
{
int len = strlen(str);

Tree * p = Root;

for(int i = 0 ;i<len;i++)
{
int ans = str[i] - 32;

while(p->next[ans]==NULL&&p!=Root) p = p->fail;

p = p->next[ans];

if(p==NULL) p =Root;

Tree *temp =  p;

while(temp !=Root &&temp->last != num)//判断之间是不是访问过
{
if(temp->Id)
{
a[top++] = temp->Id;
}

temp->last = num;

if(top>=3)//不会大于3个
{
return ;
}

temp = temp->fail;
}
}
}

int main()
{

while(~scanf("%d",&n))
{

Tree * Root;

Root = new node();

for(int i = 1;i<=n;i++)
{
scanf("%s",str);

BuildTree(i,Root);
}

BFS(Root);

int ans = 0;

scanf("%d",&m);

for(int i = 1;i<=m;i++)
{
scanf("%s",str);

top = 0;

Query(Root,i);

if(!top) continue;

printf("web %d:",i);

sort(a,a+top);

for(int j = 0;j<top;j++) printf(" %d",a[j]);

printf("\n");

if(top) ans++;
}

printf("total: %d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: