您的位置:首页 > 其它

POJ 2352 HDOJ 1541 Stars(树状数组)

2016-03-17 20:44 316 查看
Stars

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 39895 Accepted: 17312
Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an
amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are
only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at
one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
51 15 1
3 37 1
5 5
Sample Output
12
11
0
Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

题意:在一个坐标的一象限(包括点(0,0))中有n个点,每个点都有自己的等级,点(x,y)等级为它左下方点的个数,包括正左方和正下方。 输出等级0到等级n-1各有多少个点。

题解:题目数据中点按照y轴升序给出。而对于点(x,y)的左下方点的个数就是xi<=x,yi<=y的点的个数。在题中对于任意 xi 只用求得 xj<=xi,(j<=i)的 j 的个数。 最后放入level数组中统计每个等级的点的个数。

暴力法hdoj可以过,poj TLE

代码如下:

#include<cstdio>
#include<cstring>
#define maxn 32000+10
int bit[maxn];
int level[maxn/2];

int sum(int x)
{
int ans=0;
while(x>0)
{
ans+=bit[x];
x-=(x&-x);
}
return ans;
}

void add(int x)
{
while(x<=maxn)
{
bit[x]+=1;
x+=(x&-x);
}
}

int main()
{
int n,i,x,y;
while(scanf("%d",&n)!=EOF)
{
memset(bit,0,sizeof(bit));
memset(level,0,sizeof(level));
for(i=0;i<n;++i)
{
scanf("%d%d",&x,&y);
x++;//这里是允许x坐标为0的,所以将每个点横坐标都加1
level[sum(x)]++;
add(x);
}
for(i=0;i<n;++i)
printf("%d\n",level[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: