您的位置:首页 > 其它

HDU1686

2016-03-17 20:37 218 查看
 这个题目是字符串匹配算法的入门题。题目如下:

Oulipo

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 8961    Accepted Submission(s): 3619


[align=left]Problem Description[/align]
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that
counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All
the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 

[align=left]Input[/align]
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).

One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

 

[align=left]Output[/align]
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 

[align=left]Sample Input[/align]

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

 

[align=left]Sample Output[/align]

1
3
0

 
一开始的时候使用Rabin-Karp算法提交了一下,发现超时了,Rabin-karp算法最坏情况下复杂度是O(WT).然后改用了KMP算法提交才过的。KMP算法的最坏和平均时间复杂度都是O(T+W)。代码如下:

#include<iostream>
#include<string>
using namespace std;
#define SIZE 10003
int Next[SIZE];
int main(){
int i, j, m, n, ans,t;
Next[0] = -1; //初始化
string P, T;
cin >> t;
while (t--){
cin >> P >> T;
m = P.size();
n = T.size();
for (i = 1; i <=m; i++){ //Next[i]表示在P[0...i-1]中前缀后缀匹配的最大长度
j = Next[i - 1];
while (j != -1 && P[i - 1] != P[j]) //找到相匹配字符或者找到了开头也没找到匹配的字符就跳出循环
j = Next[j];
Next[i] = j + 1;
}
ans = i=j=0;
while (i <n){
while (j == -1 || (j < m&&P[j] == T[i])){
j++;
i++;
}
if (j == m)
ans++;
j = Next[j]; //前Next[j]是已匹配好的
}
cout << ans << endl;
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: