您的位置:首页 > 其它

LightOj 1234 Harmonic Number

2016-03-17 10:41 267 查看

Harmonic Number

Description

In mathematics, the nth harmonic number is the sum of the reciprocals of the first n natural numbers:





In this problem, you are given n, you have to find Hn.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 108).

Output

For each case, print the case number and the nth harmonic number. Errors less than 10-8 will be ignored.

Sample Input

12

1

2

3

4

5

6

7

8

9

90000000

99999999

100000000

Sample Output

Case 1: 1

Case 2: 1.5

Case 3: 1.8333333333

Case 4: 2.0833333333

Case 5: 2.2833333333

Case 6: 2.450

Case 7: 2.5928571429

Case 8: 2.7178571429

Case 9: 2.8289682540

Case 10: 18.8925358988

Case 11: 18.9978964039

Case 12: 18.9978964139

解题思路:

直接打表肯定会超内存,因此可以先将n分为50一组,来进行打表记录,暴力即可。

AC代码:

#include <iostream>
#include <cstdio>
using namespace std;

double a[2000005];

int main(){
double sum = 0;
for(int i = 1; i <= 1e8; i++){
sum += (1.0/i);
if(i%50 == 0)
a[i/50] = sum;
}
int T,t = 1;
scanf("%d",&T);
while(T--){
int n;
scanf("%d",&n);
int id = n/50;
sum = a[id];
for(int i = id*50+1; i <= n; i++){
sum += (1.0/i);
}
printf("Case %d: %.8lf\n",t++,sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: