您的位置:首页 > 其它

poj 3259 Wormholes(spfa) (spfa模板)

2016-03-16 22:45 357 查看
Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 39978Accepted: 14658
Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms
comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N,M (1 ≤M ≤ 2500) paths, and
W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps toF (1 ≤F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000
seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.

Line 1 of each farm: Three space-separated integers respectively: N,
M, and W

Lines 2..M+1 of each farm: Three space-separated numbers (S,
E, T) that describe, respectively: a bidirectional path between
S and E that requires T seconds to traverse. Two fields might be connected by more than one path.

Lines M+2..M+W+1 of each farm: Three space-separated numbers (S,E,T) that describe, respectively: A one way path from
S toE that also moves the traveler backT seconds.
Output
Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output
NO
YES

Hint
For farm 1, FJ cannot travel back in time.

For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
Source
USACO 2006 December Gold

题目大意:
给一个n个点的图,m条正权值边,n条负权值边,问是否存在一条回到从原点出发回到原点的路径使得权值为负。
解题思路:
建边后跑spfa即可。
p.s.:
1.注意正权值的是双向边,负权值的是单向边。
2.注意判断负环是否存在,即统计每个点如队列次数是否>n

关于负权值的总结

#include<stdio.h>
#include<string.h>
#include<queue>
#define maxv 505
#define maxe 6000//边数记得乘2
#define C(a) memset(a,0,sizeof(a))
#define C_1(a) memset(a,-1,sizeof(a))
#define C_I(a) memset(a,0x3f,sizeof(a))
#define INF 0x3f3f3f3f
using namespace std;
struct node{int to,w,next;}e[maxe];
int head[maxv],pos,d[maxv],cnt[maxv];
int F,N,M,W,a,b,c;
bool vis[maxv];
bool spfa(int s)
{
C_I(d);C(cnt);C(vis);
d[s]=0;
queue<int>Q;
while(!Q.empty())Q.pop();
Q.push(s);
vis[s]=1;
while(!Q.empty())
{
int u=Q.front();Q.pop();vis[u]=0;
for(int i=head[u];i!=-1;i=e[i].next)
{
if(d[e[i].to]>d[u]+e[i].w)
{
d[e[i].to]=d[u]+e[i].w;
if(!vis[e[i].to])
{
Q.push(e[i].to);
vis[e[i].to]=1;
cnt[e[i].to]++;
if(cnt[e[i].to]>N)return 1;
}
}
}
}
return 0;
}
void add(int from,int to,int w)
{
e[pos]=(node){to,w,head[from]};
head[from]=pos++;
}
int main()
{
scanf("%d",&F);
while(F--)
{
C(e),C_1(head);
pos=0;
scanf("%d%d%d",&N,&M,&W);
for(int i=0;i<M;i++)
{
scanf("%d%d%d",&a,&b,&c);
add(a,b,c);
add(b,a,c);
}
for(int i=0;i<W;i++)
{
scanf("%d%d%d",&a,&b,&c);
add(a,b,-c);
}
if(spfa(1)||d[1]<0)printf("YES\n");
else printf("NO\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: