您的位置:首页 > 其它

Hust oj 2113 Count(Map)

2016-03-16 20:18 381 查看
Count
Time Limit: 1000 MSMemory Limit: 32768 K
Total Submit: 113(56 users)Total Accepted: 62(53 users)Rating:





Special Judge: No
Description
Given a number of strings, can you find how many strings that appears T times?

Input
The input contains multiple test cases. Each case begins with a integer N(the number of strings you will get, N<=100000), followed by N lines, each consists of a string.

The length of each string won't longer than 20.

Output
For each test case:

There will be several lines. Echo line print two integers T and M, separated by a space.

T represents the string appears T times, M represents there are M strings that echo string appears T times.

Don't print T or M if M <= 0. The output is ordered by T, from small to large.

Sample Input
5
BBA
BBA
BEA
DEC
CCF

Sample Output
1 3
2 1

Source
ACM-ICPC黑龙江省第九届大学生程序设计竞赛选拔赛(2)

很水的一道map的题。。用数组输入之后用迭代器遍历元素,然后ans数组计数输出即可
#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
#include<map>

using namespace std;

int ans[100005];

int main()
{
int n;
int i,j,k;
char a[50];
while(~scanf("%d",&n))
{
map<string ,int>mapS;
map<string,int >::iterator it;
memset(ans,0,sizeof(ans));

for(i=1;i<=n;i++)
{
scanf("%s",&a);
mapS[a]++;
}
for(it=mapS.begin();it!=mapS.end();it++)
{
int cnt=it->second;
ans[cnt]++;
}
for(i=0;i<n;i++)
{
if(ans[i]!=0)
printf("%d %d\n",i,ans[i]);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: