您的位置:首页 > 其它

PAT (Advanced Level) Practise 1060 Are They Equal (25)

2016-03-16 19:40 411 查看


1060. Are They Equal (25)

时间限制

50 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123*105 with simple chopping. Now given the number of significant digits on a machine and
two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100,
and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line "YES" if the two numbers are treated equal, and then the number in the standard form "0.d1...dN*10^k" (d1>0 unless the number
is 0); or "NO" if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.
Sample Input 1:
3 12300 12358.9

Sample Output 1:
YES 0.123*10^5

Sample Input 2:
3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3

问用n位科学计数法表示的两个数字是否相等,情况比较多

#include<cmath>
#include<string>
#include<vector>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long LL;
const int mod = 1e9 + 7;
const int maxn = 1e3 + 10;
int n;
string a, b, c;

string change(int x)
{
string s = "";
if (x<0) s += "-", x = -x;
if (x > 10) s += x / 10 + '0';
s += x % 10 + '0';
return s;
}

string get()
{
cin >> c;
int p = c.size(), f = -1;
for (int i = 0; c[i]; i++)
{
if (c[i] == '.') p = i; else
if (c[i] != '0'&&f < 0) f = i;
}
string s = "0.";
if (f == -1)
{
for (int i = 1; i <= n; i++) s += "0";
s += "*10^" + change(0); return s;
}
if (p == c.size())
{
for (int i = 0; i < n; i++)
{
if (i <= p - f) s += c[i + f];
else s += "0";
}
s += "*10^" + change(p - f); return s;
}
if (p < c.size())
{
for (int i = 0; s.size() < n + 2; i++)
{
if (c[i + f] == '.') continue;
if (i + f < c.size())s += c[i + f];
else s += "0";
}
s += "*10^";
if (p>f) s += change(p - f);
else s += change(p - f + 1);
return s;
}
}

int main()
{
scanf("%d", &n);
a = get(); b = get();
if (a == b) cout << "YES " << a << endl;
else cout << "NO " << a << " " << b << endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT