您的位置:首页 > 其它

PAT (Advanced Level) Practise 1056 Mice and Rice (25)

2016-03-16 16:47 387 查看


1056. Mice and Rice (25)

时间限制

30 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for NP programmers. Then every NG programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in
this turn are ranked the same. Every NG winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: NP and NG (<= 1000), the number of programmers and the maximum number of mice in a group, respectively.
If there are less than NG mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains NP distinct non-negative numbers Wi (i=0,...NP-1)
where each Wi is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,...NP-1 (assume that the programmers are numbered from
0 to NP-1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.
Sample Input:
11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

其实就是规定了一种排序的方法,简单来说就是分成多组,每组最多m个,然后取每组最大的组成新的再排序,其他的都算一样大的。

#include<cmath>
#include<vector>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int mod = 1e9 + 7;
const int maxn = 1e3 + 10;
int n, m, v[maxn], a[maxn], rk[maxn], tot, b[maxn];

int main()
{
scanf("%d%d", &n, &m);
for (int i = 1; i <= n; i++) scanf("%d", &v[i]);
for (int i = 1; i <= n; i++) scanf("%d", &a[i]), ++a[i];
while (true)
{
int tot = 0;
for (int i = 1; i <= n; i++)
{
if (!rk[a[i]]) b[++tot] = a[i];
}
if (tot == 1) { rk[b[1]] = 1; break; }
for (int i = 1, j = 1; i <= tot; i++)
{
if (i%m == 0 || i == tot)
{
int now = i;
for (int k=j; k <= i; k++)
{
if (v[b[k]] > v[b[now]]) now = k;
}
for (; j <= i; j++)
{
if (j != now) rk[b[j]] = tot / m + (tot%m ? 1 : 0) + 1;
}
}
}
}
for (int i = 1; i <= n; i++) printf("%d%s", rk[i], i == n ? "\n" : " ");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT