您的位置:首页 > 其它

poj-1007-DNA Sorting

2016-03-15 20:45 549 查看
Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.
Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
求一串字符的逆序,并按逆序数从小到大的顺序排列


采用结构体

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
struct node
{
int xh;//分别求逆序数,最后排序
string str;
};
struct node ans[110];
int cmp(struct node n1,struct node n2)
{
return n1.xh < n2.xh;
}
int main()
{
int n,m,t;
cin >> n >> m;
for(int i = 0; i < m; i++)
{
t = 0;
cin >> ans[i].str;
for(int j = 0; j < n-1; j ++)
{
for(int k = j; k < n;k++)
{
if(ans[i].str[j] > ans[i].str[k])
t++;
}
}
ans[i].xh = t;
}
sort(ans,ans+m,cmp);
for(int i = 0;i < m;i++)
{
cout << ans[i].str << endl;
}
}


  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: