您的位置:首页 > 其它

HDOJ 1019 Least Common Multiple

2016-03-15 18:10 363 查看
Problem Description

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

Input

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers
in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input

2
3 5 7 15
6 4 10296 936 1287 792 1


Sample Output

105
10296最小公倍数计算时(a*b)/gcd(a,b)可能会因为a*b太大而溢出,所以要先除后乘!!!!即(a/gcd(a,b))*b!!!!!!!//
//  main.cpp
//  Least Common Multiple
//
//  Created by 张嘉韬 on 16/3/15.
//  Copyright © 2016年 张嘉韬. All rights reserved.
//

#include <iostream>
#include <cstring>
using namespace std;
int gcd(int a,int b)
{
if(b==0) return a;
else return gcd(b,a%b);
}
int lcm(int a,int b)
{
return a/gcd(a,b)*b;
}
int main(int argc, const char * argv[]) {
//freopen("/Users/zhangjiatao/Desktop/input.txt","r",stdin);
int m;
cin>>m;
for(int t=1;t<=m;t++)
{
int n,temp1,temp2;
cin>>n;
temp1=1;
for(int i=1;i<=n;i++)
{
cin>>temp2;
temp1=lcm(temp1,temp2);
}
cout<<temp1<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: