您的位置:首页 > 其它

Hdu 1050

2016-03-15 17:49 387 查看

Moving Tables

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 27023 Accepted Submission(s): 8912



[align=left]Problem Description[/align]
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only
one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the
part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the
possible cases and impossible cases of simultaneous moving.



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

[align=left]Input[/align]
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each
of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the
same manner as above.

[align=left]Output[/align]
The output should contain the minimum time in minutes to complete the moving, one per line.

[align=left]Sample Input[/align]

3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50


[align=left]Sample Output[/align]

10
20
30

/************************************************************/
//一开始思路就想错了,后来看了别人的解题思路,才发现自己错在哪里,只要思路对了就好做了这题
//要考虑到它房间的模型是1-2、 3-4、 5-6这样对着的,所以只要1占用了,2就没办法用了,要注
//意这个细节,参考别人的解题思路图



#include <iostream>
#include <string>
using namespace std;

const int N=200;
struct room
{
int from, to;
int flag;
}R
;

void device(int n)
{
int i, j;
room temp;
for(i=0; i<n-1; i++)
{
for(j=i+1; j<n; j++)
{
if(R[i].from>R[j].from)
{
temp=R[i];
R[i]=R[j];
R[j]=temp;
}
}
}

bool flag=false;
int scout=-1, to;
while(!flag)
{
flag=true;
scout++;
to=0;
for(i=0; i<n; i++)
{
if(!R[i].flag && R[i].from>to)
{
R[i].flag=1;
flag=false;
to=R[i].to;
}
}
}
cout<<scout*10<<endl;
}

int main()
{
int t, n, i;
cin>>t;
while(t--)
{
cin>>n;
for(i=0; i<n; i++)
{
cin>>R[i].from>>R[i].to;
if(R[i].from > R[i].to)
{
R[i].from=R[i].from+R[i].to;
R[i].to=R[i].from-R[i].to;
R[i].from=R[i].from-R[i].to;
}
if(R[i].from % 2 == 0)
{
R[i].from--;
}
if(R[i].to % 2 != 0)
{
R[i].to++;
}
R[i].flag=0;
}
device(n);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: