您的位置:首页 > 其它

HDUACM2054-指针处理字符串

2016-03-15 16:04 211 查看


A == B ?

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 86297    Accepted Submission(s): 13612


Problem Description

Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".

 

Input

each test case contains two numbers A and B.

 

Output

for each case, if A is equal to B, you should print "YES", or print "NO".

 

Sample Input

1 2
2 2
3 3
4 3

 

Sample Output

NO
YES
YES
NO

 

Author

8600 && xhd

 

Source

校庆杯Warm Up

 

Recommend

linle   |   We have carefully selected several similar problems for you:  2072 1002 1096 2058 1091 

#include<stdio.h>
#include<String.h>
#define max 100024
char str1[max] = {0},str2[max] = {0};
void deal(char s[]){

if(strchr(s,'.')){
int len = strlen(s);
char* q = s + len -1;
while(*q == '0'){
*(q--) = '\0';
}
if(*q=='.') *q = '\0';
}

}

int main(){
while(scanf("%s%s",str1,str2)!=EOF){

char *pa=str1 ,*pb=str2; //指针跳过前面的0
while (*pa=='0') pa++;
while (*pb == '0') pb++;
deal(pa);
deal(pb);

if(!strcmp(pa,pb)){
puts("YES");
}else{
puts("NO");
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: