您的位置:首页 > 其它

POJ 3069 Saruman's Army - 贪心

2016-03-15 14:43 399 查看
Saruman's Army

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6578 Accepted: 3355
Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units,
and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units
of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s
army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n =
−1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input
0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output
2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed
to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

Source
Stanford Local 2006
这道题和雷达那题的区别不大,只在于这里的“雷达”只能放在某个士兵身上,不是连续可放的,是离散的。把行军队列理解成一个线段,相应的策略依旧是从左端开始每放置一个雷达,要让这个雷达“消灭”其左端尽量多的士兵,这样得到的结果不会变差。那么从最左端士兵开始,每次都在其右边R范围内最靠右的士兵身上放雷达,然后以此士兵为基础把其右边R范围内的士兵排除,以此循环。需要注意的在于最后那一次放置时如果士兵身上的雷达正好将队列最右端的士兵也覆盖到了,最后的雷达数不必加一,否则需要加一。
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
int R, n;
int troops[1010];

bool cmp(int a,int b)
{
return a<b;
}

int main()
{
while (~scanf("%d %d", &R, &n))
{
if (R == n&&R == -1)
break;
for (int i = 0; i < n; i++)
scanf("%d",&troops[i]);
sort(troops, troops + n,cmp);
int key = 0;
int num = 0;
for (int i = 1; i < n; i++)
{
if (troops[i] > troops[key] + R)
{
num++;
int palantir = i - 1;
while (troops[palantir] + R >= troops[i])
{
i++;
if (i == n)
{
num--;
break;
}
}
key = i;
}
}
printf("%d\n",num+1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: